Cisco Catalyst 2950 config example with uplink trunk and static access ports

This sample config configures your Cisco Catalyst switch with;

  • Port 24: trunk port (for uplink)
  • Ports 1-23: access ports (all VLAN 4 in this example)
  • Storm control on each port
  • Enables SNMP

% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]: no

enable
config
hostname blabla.ds.connexeon.net
clock timezone CET 1
ip subnet-zero
ip name-server 85.158.106.x
ip default-gateway 85.158.106.x
ip http server
snmp-server community public RO
snmp-server location Connexeon in LCL Antwerp
snmp-server contact Connexeon NOC <
noc@connexeon.com>

interface Vlan4
ip address 85.158.106.x 255.255.255.192
no ip route-cache

interface FastEthernet0/24
switchport mode trunk
speed 100
duplex full
storm-control broadcast level 99.00
storm-control multicast level 99.00
storm-control unicast level 99.00
!
interface FastEthernet0/1
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/2
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/3
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/4
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!
interface FastEthernet0/5
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!
interface FastEthernet0/6
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!
interface FastEthernet0/7
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!
interface FastEthernet0/8
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/9
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/10
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/11
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/12
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/13
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/14
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/15
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/16
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/17
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/18
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/19
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/20
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/21
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/22
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

interface FastEthernet0/23
switchport access vlan 4
switchport mode access
storm-control broadcast level 90.00 80.00
storm-control multicast level 90.00 80.00
storm-control unicast level 90.00 80.00
!

exit

write memory